Configurando EtherChannel y 802.1Q Trunking entre Catalyst L2 Switch y un Router (InterVLAN Routing)

Continuando con etherchannel, vamos a ver como montarlo contra un router y ademas que soporte enrutamiento de VLAN en esquema router on a stick.


Configuracion del switch:
Cat2950(config)# interface port-channel 1
Cat2950(config-if)# exit
!— Asignamos puertos al canal logico para formar el EtherChannel.
Cat2950(config)# interface fa0/2
Cat2950(config-if)# channel-group 1 mode on
Cat2950(config-if)# exit
Cat2950(config)#
00:25:38: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:25:39: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
state to up
Cat2950(config)# interface fa0/3
Cat2950(config-if)# channel-group 1 mode on
Cat2950(config-if)# exit
!— Ahora ponemos el etherchannel como troncal y al igual
!— que los troncales tradicionales configuramos la VLAN nativa
Cat2950(config)# interface port-channel 1
Cat2950(config-if)# switchport mode trunk
Cat2950(config-if)#
00:27:14: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed
state to down
00:27:14: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed
state to down
00:27:14: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
state to down
00:27:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed
state to up
00:27:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed
state to up
00:27:18: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:27:19: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
state to up
Cat2950(config-if)# switchport trunk native vlan 10
Cat2950(config-if)# ^Z
00:24:12: %SYS-5-CONFIG_I: Configured from console by console
Cat2950#

Configuracion del router:
Cisco7200(config)# interface port-channel 1
Cisco7200(config-if)# exit
!— Configuramos los puertos Fa3/0 y Fa4/0 como miembros del
!— canal logico para formar el etherchannel
Cisco7200(config)# interface fa3/0
Cisco7200(config-if)# channel-group 1
FastEthernet3/0 added as member-1 to port-channel1
Cisco7200(config-if)# exit
Cisco7200(config)#
00:25:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
state to up
Cisco7200(config)# interface fa4/0
Cisco7200(config-if)# channel-group 1
FastEthernet4/0 added as member-2 to port-channel1
Cisco7200(config-if)# exit
!— Configuramos los subinterfaces sobre port channel para la VLAN 10 y VLAN 20
Cisco7200(config)# interface port-channel 1.10
Cisco7200(config-subif)# encapsulation dot1Q 10 native
Cisco7200(config-subif)# ip address 10.10.10.1 255.255.255.0
Cisco7200(config-subif)# exit
Cisco7200(config)# interface port-channel 1.20
Cisco7200(config-subif)# encapsulation dot1Q 20
Cisco7200(config-subif)# ip address 10.10.11.1 255.255.255.0
Cisco7200(config-subif)# exit
Cisco7200(config)# exit
Cisco7200#