Este post esta dirigido para mis alumnos del curso de Gestión de redes de voz y datos Vamos a ver como seria la configuración del enrutamiento de VLAN utilizando un swich de capa 3. Para ello realice un esquema con dos switch de capa 2 y uno de capa 3 que me une a un router que me lleva a Internet Las direcciones IP y nombres de cada VLAN estan en la imagen.
Solo pongo las configuraciones del switch de capa 3 y del router, las de los otros dos switches serian las básicas.
Configuraciones:
- Configuracion switch de capa 3
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SWCapa3
!
!
ip routing
!
!!
spanning-tree mode pvst
!
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/17
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/21
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/23
!
interface FastEthernet0/24
no switchport
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
switchport trunk native vlan 99
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/2
switchport trunk native vlan 99
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
ip address 192.168.20.1 255.255.255.0
!
interface Vlan99
ip address 192.168.99.1 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Si nos fijamos en la configuración en la parte en negrita tengo que habilitar el enrutamiento con ip routing y a continuacion configurar las IP para cada VLAN que seran los gateways de los equipos de cada VLAN
interface Vlan10
ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
ip address 192.168.20.1 255.255.255.0
!
interface Vlan99
ip address 192.168.99.1 255.255.255.0
!
Por último debo de configurar mi salida hacia el router y lo hago con el interfaz F0/24 poniéndolo sin switchport y asignándole una IP
interface FastEthernet0/24
no switchport
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
lo ultimo que me queda es una ruta por defecto para salir a Internet
ip route 0.0.0.0 0.0.0.0 192.168.1.1
-
Configuración de router
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 200.20.15.1 255.255.255.248
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.10.0 255.255.255.0 192.168.1.2
ip route 192.168.20.0 255.255.255.0 192.168.1.2
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
En el router la configuración es la tradicional, una ruta para salir a Internet y dos para las VLAN
ip route 192.168.10.0 255.255.255.0 192.168.1.2
ip route 192.168.20.0 255.255.255.0 192.168.1.2
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
Adjunto el fichero del Packet Tracer