Powershell

Instalar Powershell 4.0 en nuestros clientes y servidores. Windows Management Framework 4.0.

Buenos dias a todos,

Quiero empezar este nuevo camino publicando bajo el sello de ITPro hablando de Powershell, el amigo desconocido. La última versión, 4.0, disponible para su descarga desde finales del año pasado. En un post anterior ya hablamos sobre la versión 3.0 (lo podeis ver aqui) para instalarla sobre Windows 7 y Windows Server 2008 y 2008 R2,

En este caso, Microsoft ha puesto a nuestra disposición el Windows Management Framework 4.0 (WMF) que contiene un montón de caracteristicas/herramientas, ademas de PowerShell:

  • Windows PowerShell
  • Windows PowerShell ISE
  • Windows PowerShell Web Services
  • Windows Remote Managment (WinRM)
  • Windows Management Instrumentation (WMI)
  • Server Manager WMI provider
  • Windows Powershell Desired State Configuration (DSC)

Requerimientos

Necesitamos tener instalado .NET Framework 4.5 (lo podemos descargar desde este link .NET Framework 4.5)

Plataformas soportadas

  • Windows 7 con SP1
  • Windows 7 Embedded
  • Windows Server 2008 R2 con SP1
  • Windows 8
  • Windows Server 2012

En las siguientes plataformas ya viene instalada de serie:

  • Windows 8.1
  • Windows Server 2012 R2

Link de Descarga: Windows Management Framework 4.0

Comprobación

Como me dijo Juan Carlos Ruiz (Microsoft gurú de Powershell), el primer día de clase, “Podemos saber qué versión tenemos de PowerShell de cualquiera de las siguientes maneras”:

PS400000004

Seguro que se me olvida alguna. Os dejo esta ppt de una presentación que realizó este gran maestro, aunque sea de PowerShell 3.0 para Windows Server 2012 (descargar ppt)

Warning – Cuidado

Para terminar, tenemos que tener cuidado de instalar este Framework en determinados entornos en los que Microsoft, de momento, no lo recomienda, como pueden ser:

  • Microsoft Exchange 2013, Microsoft Exchange 2010 y Microsoft Exchange 2007.
  • Microsoft SharePoint 2013 y Microsoft SharePoint 2010.
  • Windows Small Business Server 2011 Standard
  • System Center Virtual Machine Manager 2008 R2 (incluyendo SP1).
  • System Center 2012 Configuration Manager (sin incluir SP1)

Seguiremos trabajando con Powershell en próximos post, con Windows Powershell Desired State Configuration (DSC) y Windows PowerShell Web Services. Y como dice LazyWinADmin, no os olvides de hacer un:

Update-Help -Verbose -Force

PS400000003

A ver si termino de configurar el WordPress y las iFeature Options. Este post está dedicado a mi compañero y responsable John.

Bibliografia interesante

LazyWinAdmin.

Windows PowerShell Blog.

DZone.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *