Welcome to Delicate template
Header
Just another WordPress site
Header

XenServer 6.5 : XenTools Out Of Date

enero 21st, 2015 | Posted by cristiansan in Citrix | ctxdom | Performance | tricks | TroubleShooting | XenServer

Tras actualizar nuestro entorno de XenServer, es momento de actualizar las tools de nuestras VMs.

Pero a pesar de estar muy agusto con XenServer y ser un hypervisor realmente potente siempre hay alguna sorpresa, para la que mas vale siempre estar preparado.

Tras actualizar las tools, he comprobado que dispongo datos de métricas correctas, y que los drivers instalados han sido actualizados, pero a pesar de ello, XenCenter sigue indicando-me, que el servidor tiene las Tools fuera de fecha.

Tras varias pruebas sin solución, @rhbBSE y @Grimdin vía Twiter me redirigieron al hilo especifico en Discussions.Citrix dónde se estaba tratando el tema.

La solución propuesta por Andreas Koch soluciono dicho inconveniente.

Solución:

Se realizan las siguientes tareas, tras tener instaladas las tools.

Ejecutamos nuevamente el INSTALLWIZARD.msi y seleccionamos la opción REMOVE.

Finalizamos el proceso, pero NO REINICIAMOS.

Si nos vamos ahora a PROGRAMS AND FEATURES veremos que sigue apareciendo la lista de componentes. NO ELIMINAR.

 Seleccionamos cada unos de los componentes y realizamos un REPAIR en el siguiente orden:

  • Citrix XenCenter Windows GUEST Agent – NO REBOOT
  • Citrix XenServer VSS Provider – NO REBOOT
  • Citrix Xen Windows x64 PV Driver

El repair de los Drivers de paravirtualización nos solicitará un reinicio. Reiniciamos el Servidor, y una vez finalizado el proceso, veremos ya nuestra máquina con el sistema “Optimizado”.

NOTA: Agradecer a @rhbBSE y @Grimdin esa pequeña gran ayuda via twiter. Mil gracias!

Post: http://discussions.citrix.com/topic/359775-xenserver-65-updating-xentools-from-620-hotfix-1016-65-no-go/?p=1854149

You can follow any responses to this entry through the RSS 2.0 You can leave a response, or trackback.

3 Responses

  • Fernando Giraldo says:

    Hola, gracias por la guía me sirvió mucho. Me pasa que ahora tengo el mismo problema pero con MV Linux, una debian y otra centOS. La solución en un win server 2012 me funcionó perfecto, tienes alguna idea de como puedo instalar las tools en los huéspedes Linux?

    gracias.

  • Las Xentools incluyen un instalador en shell (.sh) para las tools en las maquinas Linux. El primer Fix de XS65 de echo soluciono este punto.

    Si tienes cualquier problema, te podemos ayudar desde los foros de CTXDOM.COM.

    un saludo Fernando 😉

    • Fernando Giraldo says:

      Cristian gracias por responder… yo continúo con el problema, ingreso por la consola voy a la carpeta linux ejecuto ./install, comienza el proces y sale que ya el paquete está instalado… sin embargo en el menú de xencenter sigue apareciendo que no están instaladas, y no puedo por ejemplo ver el consumo de RAM de esas máquinas.

      Ya me voy a registrar en ctdxdom para buscar ayuda allá

      gracias



Leave a Reply to cristiansan Cancel reply

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *