Curso Validación de datos en Excel – Parte #3 – Manejo de valores duplicados

VER PARTE #2 – MANEJO dE VALORES DUPLICADOS CON VALIDACIÓN DE DATOS

Manejo de duplicados

En esta cuarta entrega del curso de Validación de datos veremos un caso típico en donde requerimos que sólo se acepten registros únicos dentro de un rango.

Se prohibirán los valores duplicados.

Figura 1. Se prohibirán los valores duplicados.

Ver Video Validación de datos en Excel – Parte #3 – Valores duplicados

SUSCRÍBETE a EXCELeINFO en YouTube para aprende más de Excel.

Usando CONTAR.SI para permitir registros únicos

La función CONTAR.SI nos ayudará a hacer un conteo de las veces en que un valor se encuentra dentro de un rango. En la parte izquierda de nuestra columna ingresamos la siguiente fórmula:

=CONTAR.SI($C$5:$C$11,C5)=1

Ahora, en la Figura 2 vemos cómo la fórmula nos devuelve verdadero cuando sólo hay un valor único en el rango.

Nos devuelve VERDADERO cuando se encuentra un registro único.

Figura 2. Nos devuelve VERDADERO cuando se encuentra un registro único.

Configurando la regla personalizada

La misma fórmula que usamos en la celda, la usaremos como regla personalizada en Validación de datos. Copiamos la fórmula, elegimos el rango [C5:C11]. Nos dirigimos a Datos > Validación de datos. En la pestaña Configuración elegimos Permitir > Personalizada. Pegamos la fórmula. Posteriormente configuramos los mensajes de entrada y de error, como lo vemos en las Figuras 4 y 5.

Definimos fórmula personalizada.

Figura 3. Definimos fórmula personalizada.

Configuramos mensaje de entrada.

Figura 4. Configuramos mensaje de entrada.

Se mostrará un mensaje de advertencia si se ingresa un duplicado, pero lo dejará pasar.

Figura 5. Se mostrará un mensaje de advertencia si se ingresa un duplicado, pero lo dejará pasar.

Validacion de datos en Excel

Figura 6. Animación de Validación de datos.

Descarga el ejemplo

Descargar el ejemplo EXCELeINFO – Validación de datos en Excel #3 – Manejo de valores duplicados.zip

 

VER PARTE #2 – MANEJO dE VALORES DUPLICADOS CON VALIDACIÓN DE DATOS

You may also like...

Leave a Reply / Deja un comentario

Follow

Get every new post delivered to your Inbox

Join other followers